Can we discuss some block naming issues? Personally, I'm against:
STONE_BRICKS
Because we have "BRICK". Why not "STONE_BRICK"? That frustruates me... Besides, we have "NETHER_BRICK" as well!
Another issue I have with naming - step/doublestep and slab/doubleslab.
My suggestion is to make enums inside MCS source and in items.ini similar.
- Replace "STONE_BRICKS" with "STONE_BRICK"
- Remove "slab" and "doubleslab" from items.ini (and crafting as well)
- Remove "slimeorb" from items.ini (because we have SLIMEBALL in iternal structure)
If you appretiate such changes, I could fix items.ini and crafting.txt as well
Two more things: Rails. I suggest using "RAIL" everywhere. Because of "powered_rail" and "detector_rail".
And this:
E_ITEM_LEATHER_TUNIC = 299,
E_ITEM_LEATHER_PANTS = 300,
Why not Chestplate and Leggins (like with other armor types)?
Okay, I've done it. BlockID.h is now complete (even more complete than it should be: 1.3-ready)
I DIDN'T any changes to existing naming, BUT used "stone_brick" approach for new entries.
STONE_BRICKS
Because we have "BRICK". Why not "STONE_BRICK"? That frustruates me... Besides, we have "NETHER_BRICK" as well!
Another issue I have with naming - step/doublestep and slab/doubleslab.
My suggestion is to make enums inside MCS source and in items.ini similar.
- Replace "STONE_BRICKS" with "STONE_BRICK"
- Remove "slab" and "doubleslab" from items.ini (and crafting as well)
- Remove "slimeorb" from items.ini (because we have SLIMEBALL in iternal structure)
If you appretiate such changes, I could fix items.ini and crafting.txt as well
Two more things: Rails. I suggest using "RAIL" everywhere. Because of "powered_rail" and "detector_rail".
And this:
E_ITEM_LEATHER_TUNIC = 299,
E_ITEM_LEATHER_PANTS = 300,
Why not Chestplate and Leggins (like with other armor types)?
Okay, I've done it. BlockID.h is now complete (even more complete than it should be: 1.3-ready)
I DIDN'T any changes to existing naming, BUT used "stone_brick" approach for new entries.