Webadmin randomly stops working
no errors in console, works fine then it just throws err_timed_out in google chrome. browser open on my personal computer, mcserver running @ datacenter. most likely a problem with your httpd. restarting MCServer doesn't fix it. it fixes itself when it feels like it.

[Image: aGlt5D8.jpg]

[Image: mNtJmnV.jpg]

mcserver is installed on a ubuntu 15.04 minimal VM running under its own user in proxmox 3.4 with dedicated IP on a dedicated server that is practically idle and barely running anything
Thanks given by:
It's the first time I see such a problem, I'm running the Gallery server on a RasPi and access it via webadmin pretty often, and haven't had any such problem yet.

When it happens again that your browser won't connect, can you run a "netstat -na" in the VM? It'd be interesting to see what connections are currently established and what ports are being listened on.
Also, try a local browser inside the VM (if you don't have graphical access, use the "links" text-mode browser for example).

Where I'm aiming with this: An explanation could be that the browser is using keep-alive connections and the Cuberite http parser doesn't understand them correctly, so the connections get stalled. The browser has a limit of per-server connections it's allowed to use, when it reaches the limit and all the connections are "dead", it claims the server unresponsive. The fix that happens after some time is the browser actually closing some of those connections due to timeouts or possibly other causes.
It's far-fetched, but it's the best I've got so far Smile
Thanks given by:
mcserver@shane:~$ netstat -na
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp6 0 0 :::8080 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 :::25565 :::* LISTEN
udp 0 0*
udp 0 0*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 4985421 /var/run/fail2ban/fail2ban.sock
unix 2 [ ] DGRAM 4943216 /run/systemd/notify
unix 2 [ ACC ] STREAM LISTENING 4943218 /run/systemd/private
unix 2 [ ACC ] SEQPACKET LISTENING 4943227 /run/udev/control
unix 2 [ ] DGRAM 4943258 /run/systemd/shutdownd
unix 2 [ ] DGRAM 4944046 /run/systemd/journal/syslog
unix 2 [ ACC ] STREAM LISTENING 4943281 /run/systemd/journal/stdout
unix 5 [ ] DGRAM 4943284 /run/systemd/journal/socket
unix 3 [ ] DGRAM 4943545 /run/systemd/journal/dev-log
unix 3 [ ] STREAM CONNECTED 6433731
unix 3 [ ] STREAM CONNECTED 6433730
unix 2 [ ] DGRAM 6433720
unix 3 [ ] STREAM CONNECTED 4995513 /run/systemd/journal/stdout
unix 3 [ ] STREAM CONNECTED 4995512
unix 2 [ ] DGRAM 4944908
unix 3 [ ] STREAM CONNECTED 4944858 /run/systemd/journal/stdout
unix 3 [ ] STREAM CONNECTED 4944849
unix 3 [ ] STREAM CONNECTED 4944689 /run/systemd/journal/stdout
unix 3 [ ] STREAM CONNECTED 4944684
unix 2 [ ] DGRAM 4944167
unix 3 [ ] DGRAM 4943682
unix 3 [ ] DGRAM 4943681
unix 2 [ ] DGRAM 4943449
unix 3 [ ] STREAM CONNECTED 4944150 /run/systemd/journal/stdout
unix 3 [ ] STREAM CONNECTED 4943358
Thanks given by:
Okay, that rules my idea out.

Anyone else wants to try? Smile
Thanks given by:
when i issue a restart command to the server while the webadmin is unresponsive i get this error:

[17:30:46] HTTP server error on port 8080: 98 (Cannot bind IPv6 socket to port 8080: 98 (Address already in use))
Thanks given by:
1. Use HTTP.
2. Turn off IPv6 on interface. Use Google.
3. Check the error exists on HTTP.
4. If not exists. Use HTTPS and test without IPv6.
5. Say us for your result Smile

tcpdump make help too.
Thanks given by:
tcp6 0 0 :::8080 :::* LISTEN
tcp6 0 0 :::25565 :::* LISTEN

its listening on ipv6 even though i've disabled it multiple ways and don't have an ipv6 address. how do i change that?
Thanks given by:
I'm do not use Ubuntu. I'm on FreeBSD. But Google says:
And first link:
Thanks given by:
so i found a way to make it screw up... when it finally decides to work (no rhyme nor reason) if you simply click one of the menu items 3-5 times fast it will crash and give err_timeout for at least 10min. guaranteed way to make it mess up, however it just screws up randomly as well.

i went through each menu 20+ times slowly and it worked flawlessly until i clicked server settings a bunch of times quickly. reproduced this method 3 times
Thanks given by:
Can you identify the version you're using? Wither a commit SHA1 checksum, or build number (if downloaded from the official buildserver). There was a recent fix to some network issues (sigpipe handler) that could be related, I want to know if you have that fix in or not.
Thanks given by:

Users browsing this thread: 1 Guest(s)