Compilation failed ><

So I tried to compile cuberite and... miserably failed :/

Here's the error:

cc1plus: error: unrecognized command line option ‘-fstack-protector-strong’

src/Mobs/CMakeFiles/Mobs.dir/build.make:86: recipe for target 'src/Mobs/CMakeFiles/Mobs.dir/Bat.cpp.o' failed
make[2]: *** [src/Mobs/CMakeFiles/Mobs.dir/Bat.cpp.o] Error 1

The GCC was 5.4.0 and it's ARM and well... I have no idea :/
But would be thankfull for any tips Smile
Thanks given by:
mikroseem gave me this tip:

that error means the gcc you have installed wasn't compiled with features Cuberite requires.

Okay let's see, if I can get something more usefull.
Btw. I am using Armbian here

They dropped the flag... anybody update pretty please ? ^^
Thanks given by:
Hello, welcome to the forum.

I don't think Cuberite itself sets that flag, it seems it's coming from your OS / compiler by default. From what I've read, you could simply override it with `-fstack-protector-none` or `-fstack-protector-all`.
Do an `echo $CFLAGS` and `echo $CXXFLAGS` on your command line, inspect if the bad flag is listed; if so, have a look where it could be set - usually in ~/.profile, ~/.bashrc or similar. Remove it from there, log in in a new session and try again.
Alternatively, it should be possible to do something like `CFLAGS="$CFLAGS -fstack-protector-none" CXXFLAGS="$CXXFLAGS -fstack-protector-none" cmake <cuberitedir>` when configuring Cuberite for the first time.
Note that I'm not too familiar with Linuxes, so the commands I gave you might need some tweaking.
Thanks given by:

Users browsing this thread: 1 Guest(s)