[Done] Volunteer needed :)
#1
It seems that there sometimes are volunteers who can do stuff relevant to MCServer, if not directly coding, then at least related.

I'd need such a volunteer now Smile

I need someone to go through the source file source/BlockID.h and add the block types, item types and block and item metas there. There should be enough in that file to get you started on the format (it's a regular C++ file; each value belongs to a category, categories are clearly split, etc.).
You can download the current version off the web, too, if you don't have an SVN client, from here:
https://code.google.com/p/mc-server/sour.../BlockID.h (either copy the contents of the webpage, or use the link on the very right, "View raw file"

Thank you in advance, whoever you will be. The community will remember you Smile
Reply
Thanks given by:
#2
I would like to help, but I don't get what you want -_-
I suppose you forgot to insert link in word "there" or I'm missing something... Could you explain your need?
Reply
Thanks given by:
#3
there = into the file (and attach the file to the thread here). Download link for the file is given.
Reply
Thanks given by:
#4
You mean sort of "block_name = block_ID" (and same for items, etc.), or "enum_name = block_ID" ("cleaned up" BlockID.h)?
So far blocks' enums seems to be complete...
BlockMetas' enums aren't, however... Do you need me to complete (align, make up to date) BlockID.h for Minecraft 1.2.5?
Reply
Thanks given by:
#5
Keep the format that's already in the file - inside the enums, there's E_BLOCK_XXX=YYY, but there are a few missing. I need all those missing blocks, items and metas to be there in this way.
Reply
Thanks given by: Taugeshtu
#6
Can we discuss some block naming issues? Personally, I'm against:
STONE_BRICKS
Because we have "BRICK". Why not "STONE_BRICK"? That frustruates me... Besides, we have "NETHER_BRICK" as well!

Another issue I have with naming - step/doublestep and slab/doubleslab.

My suggestion is to make enums inside MCS source and in items.ini similar.
- Replace "STONE_BRICKS" with "STONE_BRICK"
- Remove "slab" and "doubleslab" from items.ini (and crafting as well)
- Remove "slimeorb" from items.ini (because we have SLIMEBALL in iternal structure)

If you appretiate such changes, I could fix items.ini and crafting.txt as well
Two more things: Rails. I suggest using "RAIL" everywhere. Because of "powered_rail" and "detector_rail".

And this:
E_ITEM_LEATHER_TUNIC = 299,
E_ITEM_LEATHER_PANTS = 300,
Why not Chestplate and Leggins (like with other armor types)?

Okay, I've done it. BlockID.h is now complete (even more complete than it should be: 1.3-ready)

I DIDN'T any changes to existing naming, BUT used "stone_brick" approach for new entries.


Attached Files
.txt   BlockID.txt (Size: 16.2 KB / Downloads: 212)
Reply
Thanks given by: xoft
#7
I'm somewhat against removing items, because some people, or even worse, plugins, may be using them. Most of those names are what those things used to be called in the older versions of MineCraft, so they are, technically, valid.
Of course, using the "official" names is better, and for new items, I think the official names should be used, but let's not break things (yet).

Thanks for the changes, that was exactly what I was after. I had already done some modifications to that file myself, so I had to merge the changes, but your work is definitely appreciated. I will commit the changes when I verify that they didn't break any code.
Reply
Thanks given by:




Users browsing this thread: 1 Guest(s)