Having an issue with the Cuberite Plugin Checker and Travis
#1
Let me preface this by saying it does not appear to be a problem with CPC (or if it is, it's exclusive to the CI readme's instructions). It's either in my travis setup or something I don't know about.

Starting with the repository: https://github.com/Zee1234/Dependency

Now the error:
Code:
[color=#000000]$ lua CuberitePluginChecker.lua -p $TRAVIS_BUILD_DIR -a ~/AutoAPI -e ~/ManualAPI.lua -i APIImpl/All.lua -s $TRAVIS_BUILD_DIR/tests/first.lua -g

Loading AutoAPI from path /home/travis/AutoAPI
Loading ExtraAPI file "/home/travis/ManualAPI.lua".
Loading API implementation file "APIImpl/All.lua".
lua: error loading module 'lsqlite3' from file '/home/travis/build/Zee1234/Dependency/lua_install/lib/lua/5.1/lsqlite3.so':
/home/travis/build/Zee1234/Dependency/lua_install/lib/lua/5.1/lsqlite3.so: undefined symbol: sqlite3_db_filename
stack traceback:
[C]: ?
[C]: in function 'require'
APIImpl/Misc.lua:9: in main chunk
[C]: in function 'dofile'
APIImpl/All.lua:28: in function 'f'
ApiLoader.lua:302: in function 'loadApiImplementations'
ApiLoader.lua:535: in function 'load'
CuberitePluginChecker.lua:27: in main chunk
[C]: ?


The command "lua CuberitePluginChecker.lua -p $TRAVIS_BUILD_DIR -a ~/AutoAPI -e ~/ManualAPI.lua -i APIImpl/All.lua -s $TRAVIS_BUILD_DIR/tests/first.lua -g
" exited with 1.

Done. Your build exited with 1.[/color]

Full log is here: https://api.travis-ci.org/jobs/213994618...eansi=true

I have tried numerous 'fixes' with the .travis.yml (read: nothing I figured would actually fix it, based on the type of error, but I wanted to get past the obvious possible mistakes first). This included taking the .travis.yml example code from https://github.com/cuberite/CuberitePlug...ingInCI.md and using it directly (having made the needed directory and file name changes). Exact same error.

So yeah, I have no clue even what this error is, honestly. I tried googling 'undefined symbol: sqlite3_db_filename' and I got a lot of LuaJIT FFI stuff which I'm fairly certain isn't totally relevant (but idk, maybe it is?) Any help is appreciated, this is my first time messing with CI.


PS: yes I did (just) notice that the script isn't currently set up to be USING luacov, but it ended up not mattering (so far) because the build was never successful. And yes, I do plan to set up a better test at some point.
I sometimes write plugins! But I've not really "published" any of them, except my first, and worst, one. Feel free to explore my stuff here: my github page
Reply
Thanks given by:




Users browsing this thread: 1 Guest(s)