Strange server behavior
#1
Bug 
Hello there people, so I was messing around with the server, posting it on some listings and stuff like that. I saw a user joined so I wanted to see what was going in it, I joined and realized that I couldn't interact at all. At first glance I thought it was lag because some of my plugins just decided to fail but they weren't the ones to blame, I disabled all of the resource-intensive plugins and I'm still facing the same behavior.

Enabled plugins:
  • GraveChest (version 0)
  • Essentials (version 3)
  • WorldEdit (version 14)
  • Core (version 16)
  • Login (version 3)
  • Permissions (version 5)
  • ChatLog (version 3)
  • SkyBlock (version 4)
  • Query (version 1)
  • InventorySpy (version 0)
Mobs and chunks DO behave as normal, I just can't neither interact with mobs nor trigger chunks generation by moving around. Server resources don't look hogged up and it doesn't really behave as if it was overloaded, TPS go around 19.96 up to a perfect count of 20 TPS.

The server doesn't crash so I can't provide any logs about the issue, that way, I'm providing a capture of such behavior so that you can give me a hand on it.



Hope you can help me get this solved, and thank you in advance!
Reply
Thanks given by:
#2
I can't really see in the video what the problem is, but the server keeps telling you to login, so I'd expect the Login plugin to be the issue here.
Reply
Thanks given by:
#3
(04-30-2020, 04:56 PM)xoft Wrote: I can't really see in the video what the problem is, but the server keeps telling you to login, so I'd expect the Login plugin to be the issue here.

Well, I think it might not be as self-explanatory as it was inside of my brain now that you said that lol. Thing's that, I try to login, but nothing happens, I try to break a block, nothing gets dropped, a couple seconds ago, I get a response but it's not useful, it would just roll me back to the spawn.

Would you like me to try to disable Login an record another video? I did already, but it might be easier for you to tell what else could it be.
Reply
Thanks given by:
#4
I don't need a video. But disabling the Login plugin and trying again is a good idea. Could be basically any other plugin, too. So disable them all first to see if it's the server doing this; if not, there's your answer Smile
Reply
Thanks given by:
#5
(04-30-2020, 10:25 PM)xoft Wrote: I don't need a video. But disabling the Login plugin and trying again is a good idea. Could be basically any other plugin, too. So disable them all first to see if it's the server doing this; if not, there's your answer Smile

So I disabled all third-party plugins and I'm still facing the same behavior. Here's a full log, or is there any extra logging that I can enable?

https://del.dog/yulelimemi.txt

UPDATE: Problem identified, the only problematic world is "world" (the default world), so it's very likely that there's some undetected corruption. I'll make an archive of it for future investigation and then I'll try to repair it. Also, if I shut down the server, changes to "world" aren't saved, but every other world does.
Reply
Thanks given by:
#6
That's very odd, you should certainly send a copy of the world file so we can see what's gone wrong and try to fix it.

Glad you managed to work out the problem though Smile
Reply
Thanks given by: facuarmo
#7
(05-01-2020, 07:45 PM)bearbin Wrote: That's very odd, you should certainly send a copy of the world file so we can see what's gone wrong and try to fix it.

Glad you managed to work out the problem though Smile

Alright, so just FTR, I got this world through MCEdit's prune operation and this region fixer, none of them detected any corruption. 

Here's the archive:

https://1drv.ms/u/s!Aqd6Z0lmR7limw0QmhhH...S?e=64QWGQ

I really hope that some of you can shed some light about this issue, I'd be glad if I could get this fixed, it's not that the world's content is that important, I just want to dig deep into the issue as it seems to be directly related to either Cuberite or my server's setup.
Reply
Thanks given by:




Users browsing this thread: 1 Guest(s)