Crash when login with client on linux
#11
I've tried fixing the one thing that kept crashing on me - although I don't think it's the same thing. Give it a try, please.
http://ci.berboe.co.uk/job/MCServer%20Linux-x86/731/
Reply
Thanks given by:
#12
No dice D:

Try reverting the changes to GNUMakefile in:
http://ci.berboe.co.uk/job/MCServer%20Li...87/changes
http://ci.berboe.co.uk/job/MCServer%20Li...84/changes

If not, try reverting:
http://ci.berboe.co.uk/job/MCServer%20Li...88/changes

Or maybe have a look at them. The server definitely crashes after CI build 688 (pumpkins etc.)

I got another backtrace with gdb:


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xacdb0b70 (LWP 4456)]
0xb7fa3a47 in std::string::append(char const*, unsigned int) () from /usr/lib/i386-linux-gnu/libstdc++.so.6
(gdb) bt
#0  0xb7fa3a47 in std::string::append(char const*, unsigned int) ()
   from /usr/lib/i386-linux-gnu/libstdc++.so.6
#1  0x08235ccc in WriteByte (a_Value=3 \'\003\', this=0x9426bd8) at source/Protocol/Protocol.h:123
#2  cProtocol125::SendChat (this=0x9426bd8, a_Message=...) at source/Protocol/Protocol125.cpp:217
#3  0x08237a35 in cProtocol161::SendChat (this=0x2c, a_Message=...) at source/Protocol/Protocol16x.cpp:82
#4  0x081f8c46 in tolua_AllToLua_cPlayer_SendMessage00 (tolua_S=0x8655750) at source/Bindings.cpp:8326
#5  0x08176ea2 in luaD_precall (L=L@entry=0x8655750, func=<optimized out>, func@entry=0x869dffc,
    nresults=nresults@entry=0) at lua-5.1.4/src/ldo.c:319
#6  0x0815d0ad in luaV_execute (L=L@entry=0x8655750, nexeccalls=2, nexeccalls@entry=1)
    at lua-5.1.4/src/lvm.c:587
#7  0x081777a8 in luaD_call (L=L@entry=0x8655750, func=0x869df9c, nResults=1) at lua-5.1.4/src/ldo.c:377
#8  0x08172460 in f_call (L=L@entry=0x8655750, ud=ud@entry=0xacdafd98) at lua-5.1.4/src/lapi.c:800
#9  0x08176614 in luaD_rawrunprotected (L=L@entry=0x8655750, f=f@entry=0x8172440 <f_call>,
    ud=ud@entry=0xacdafd98) at lua-5.1.4/src/ldo.c:116
#10 0x08177a33 in luaD_pcall (L=L@entry=0x8655750, func=func@entry=0x8172440 <f_call>, u=u@entry=0xacdafd98,
    old_top=36, ef=0) at lua-5.1.4/src/ldo.c:463
#11 0x08175503 in lua_pcall (L=0x8655750, nargs=1, nresults=1, errfunc=0) at lua-5.1.4/src/lapi.c:821
#12 0x08219784 in cLuaState::CallFunction (this=0x86153c0, a_NumResults=1) at source/LuaState.cpp:725
#13 0x08395377 in Call<int, cPlayer*, bool> (a_Ret1=<optimized out>, a_Arg1=<optimized out>,
    a_FnName=<optimized out>, this=<optimized out>, a_Mark=...) at source/LuaState.h:238
#14 cPluginLua::OnPlayerJoined (this=0x8615380, a_Player=...) at source/PluginLua.cpp:637
#15 0x083592a5 in cPluginManager::CallHookPlayerJoined (this=0x85cc580, a_Player=...)
    at source/PluginManager.cpp:669
Reply
Thanks given by:
#13
(09-16-2013, 11:26 PM)xoft Wrote: I've tried fixing the one thing that kept crashing on me - although I don't think it's the same thing. Give it a try, please.
http://ci.berboe.co.uk/job/MCServer%20Linux-x86/731/

It still crashes Sad
Reply
Thanks given by:
#14
I get a crash in my VM, too, but it seems that it's in a different place, it's inside CryptoPP! Weird.
Reply
Thanks given by:
#15
Try reverting my suggestions about the makefile, I dunno.
Reply
Thanks given by:
#16
I recompiled and it's gone, I can normally play. Suppose some leftovers were kept from previous compilations
Reply
Thanks given by:
#17
Good to hear.

BEARBIN, YOUR SERVER IS BROKE!Big Grin
Reply
Thanks given by:
#18
Carlossg, can you compile the server yourself?

You need to get the sources, then run make release=1 to build them:
Code:
mkdir mc-server
cd mc-server
git clone https://github.com/mc-server/MCServer.git .
make release=1
cd MCServer
./MCServer

If you don't have git installed, you need to install it first:
Code:
sudo apt-get install git
Reply
Thanks given by:
#19
If I do that server works, but world is underwater and commands doesnt work(Plugins?)

:D
Reply
Thanks given by:
#20
Just replace executable when updating.
Combustible lemons and potato batteries, that's the future.Big Grin
Reply
Thanks given by:




Users browsing this thread: 1 Guest(s)